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T HIS software is a program for designing the curves of a violin body (mould). There are various methods for

designing a violin mould, but most are either too complex or difficult to modify in part, making them impractical

for actual instrument making. The most significant problem is the presence of discontinuities on the curves,

resulting in curves that are not truly smooth. This is a consequence of the design method that joins two circular arcs of

different radii: at the junction point, a subtle kink (discontinuity) is visually perceptible. Moreover, real instruments use

curves whose curvature changes gradually, not perfect circular arcs.

To address these problems, this program uses Clothoid curves instead of circular arcs. A Clothoid curve is a curve whose

curvature changes progressively, providing an extremely smooth result. However, when the bending direction is the same,

there is only one possible Clothoid curve connecting two fixed points — its shape cannot be changed. This means it

cannot express the wide variety of curves found on different instruments. To solve this, the program uses a curve formed

by connecting three Clothoid curves into one (referred to in this manual as a Multi-Clothoid curve). Because there are no

discontinuities at the junctions between the three segments, the overall curve is extremely smooth, and a wide variety of

shapes can be freely generated.

Violin Designer, ver.3.0.0 includes changes and additions to some features and terminology, and this user manual has been

newly written.



The Reconstruction of the Stradivari Arch

1 Changes in ver.3.0.0

• Partial changes to the main window UI and terminology

• Changed the input unit for curve curvature (CUR.) values (previously entered as 0.004, now entered as 4.0 — larger

numbers are now used)

• Changed/added result graph display methods and items

- Changed to radio buttons: [Overlap Graph / Redraw Graph / New Graph]

- Added Reference line to [Arch Profile]

• Separated file save button

• Added timestamp to filename when saving (NewDesign.pdf > New_Design_2026-02-21_20-12-20.pdf)

• Added config file Import/Export feature

• Added Reference image feature

• Other bug fixes
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2 Features

2.1 Design

• Automatic design using Multi-Clothoid curves

• Automatic calculation of corner width (Method H.I.S.)

• Selection of display items (layers) for the result curve

• Selection of update method for the result curve

• Reference image display for instrument reference

• Import and Export of setting values

• Preset initial values for each instrument type

2.2 Output

• On-screen display of result curves

• PDF file output of result curves

• DXF file output of result curves

• TXT file output of result curve numerical values

2.3 Analysis

• Display of parameter values used in the design

• Display of numerical values for each section

• Display of proportional values for each section
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3 Installation

This software is a portable version, so no installation is required. Simply extract the archive and double-click Vio-

lin_Designer_v.X.X.X.exe to launch the program immediately. Note that depending on your computer’s specifications,

startup may take some time.

Please observe the following points during installation and program launch:

■ Run as Administrator

If the Violin_Designer_v.X.X.X folder is located inside a Windows system folder such as Program Files on the C drive, you

must run the program with [Run as Administrator]. Otherwise, the program may not function correctly, and PDF, DXF, or

TXT files may not be saved properly.

■ Windows Security Settings

When extracting the archive, Windows Security may automatically delete certain files, flagging them as suspicious. If

this occurs, go to Windows Security settings, restore the quarantined files, and then re-extract the archive. This software

contains no viruses of any kind.
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4 How the Program Works

4.1 Control Points and Reference Points

This program designates multiple control points and connects them with curves. Since string instruments are bilaterally

symmetrical, the program draws the left-side outline based on the vertical centerline of the instrument body, then mirrors

it to complete the right side.

Control points determine the length and width of the instrument body; connecting these points completes the body curve.

Reference points are used for calculation and analysis. The user does not specify point positions directly — instead,

the instrument dimensions (height and width) are entered, and the program automatically calculates the positions of all

control points and reference points.

Multi-Clothoid curves are used to connect the control points. A Multi-Clothoid curve consists of three Clothoid curves

joined into one using G2 Hermite Interpolation; the three segments are displayed in different colors. Changing the position

of a point or modifying the parameter values of a Multi-Clothoid curve changes the shape of the curve.

Figure 1: Control points (red) and reference points (green)
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4.2 Clothoid Curve

A Clothoid curve is a curve whose curvature increases as the length of the curve increases — it progressively curves more

tightly, spiraling inward. - Figure.2 (a) -

Because a Clothoid curve matches the path traced by a car traveling at constant speed while its steering wheel is turned

at a constant rate, it is commonly used as a transition curve in highway bends. The red line in Figure.2(b) is a Clothoid

curve. In highway terms: when transitioning from a straight road (blue) into a circular curve (green), the Clothoid curve

gradually reduces the turning radius.

(a) Clothoid curve (b) Clothoid curve on a highway

Figure 2: Clothoid curves
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4.3 Multi-Clothoid Curve

When connecting two control points at fixed positions with a single Clothoid curve, if the curve direction at both points

does not change, there is only one possible Clothoid curve connecting them. This is a significant limitation for violin

design: if the instrument dimensions are the same (i.e., the control points are in the same positions), only one possible

design can be produced.

Figure.3(a) shows a single Clothoid curve connecting points A and B. As long as the curve direction at A and B remains

unchanged, the shape cannot be altered. Figure.3(b) shows the same two points connected by a Multi-Clothoid curve,

where only the curvature is changed while the curve direction at A and B is maintained. As shown, an infinite variety of

shapes can be generated. In other words, Multi-Clothoid curves allow diverse curve shapes to be created without changing

the positions or directions of the control points.

(a) Single Clothoid curve (b) Multi-Clothoid curve

Figure 3: Single Clothoid vs. Multi-Clothoid curve

The Multi-Clothoid curve described in this manual refers to a single curve formed by joining three individual Clothoid

curves using G2 Hermite Interpolation. The three segments are rendered in different colors so they can be visually distin-

guished.
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4.4 Changing the Shape of a Multi-Clothoid Curve

When two points are connected by a Multi-Clothoid curve, the shape of the curve is determined by the direction and

curvature of the curve at each point.

■ Direction

The shape of the curve changes according to the direction (angle, East = 0◦) in which the curve is heading. Figure.4 shows

Multi-Clothoid curves with different directions at the start and end points. The left figure departs at 272◦, the center figure

departs at 300◦. The right figure shows a case where the direction at the end point differs. Note that the curve direction

is always defined relative to the direction of travel. In the center figure, the curve direction at end point B is 231◦; in the

right figure it is 200◦.

Figure 4: Shape changes of Multi-Clothoid curves with varying curve direction

※ Note ※
All angle calculations described above apply to the left-side curve only.
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■ Curvature (Magnitude and Sign)

Curvature determines the degree of bending: a larger absolute value (= smaller radius of curvature) means a sharper bend;

a smaller value means a gentler bend. The +/- sign determines the direction of the bend. A positive curvature bends to the

left relative to the direction of travel; a negative curvature bends to the right.

Figure.5 shows how the curve changes when the curvature value (absolute value) and sign are varied while the direction

at start point A remains constant. The left figure shows curvature = -100: the negative sign means it bends to the right,

and the large absolute value means the bend is sharp. The right figure shows curvature = +100: positive sign and large

absolute value, so it bends sharply to the left. The center figure shows curvature = 0: the curve extends straight in the

defined direction with no bending.

Figure 5: Shape changes of Multi-Clothoid curves with varying curvature sign and magnitude

※ Note ※
As with the angles above, these rules apply to the left-side curve only. On the right-side curve, the sign of the curvature is

reversed.
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5 Screen Description

5.1 Main Window

※ In v.3.0.0, the UI layout, positions, terminology, and some content have been partially changed.

The [Main Window] is divided into 5 areas, each with the following roles:

• Area (A): Drawing name input, Preset buttons, and a diagram showing control points and reference points

• Area (B): Basic settings and instrument dimensions for drawing

• Area (C): Shape settings for the 8 Multi-Clothoid curves

• Area (D): Selection of items to display on the drawing

• Area (E): Draw and file save buttons

Figure 6: Main Window
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5.2 Result Window

※ In v.3.0.0, the Reference image is now also displayed in the Result Window.

This is the [Result Window] that appears on screen when the [Calculate & Draw] button is clicked in the [Main Window].

Everything displayed on screen can be saved in identical form to PDF, DXF, and TXT files. The left side of the [Result

Window] shows points, curves, values, and the Reference image; the right side shows setting values and analysis values.

The items displayed here can be toggled on or off under LAYER (Area D) in the [Main Window].

Figure 7: Result Window
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5.3 Reference Image Setting Window

※ Added in v.3.0.0.

This window is used when you want to design by referring to a photo of an instrument, or when you want to trace its shape

directly.

It is opened by clicking [Tools > Reference Image] in the top menu of the [Main Window]. Load a prepared instrument

photo, then adjust its position, size, and so on. Multiple Reference lines can also be set to help measure the instrument’s

dimensions.

Figure 8: Reference Image Setting Window

• Guide-h1/2/3: Horizontal Reference lines for height reference

• Guide-w1/2/3: Vertical Reference lines for width reference

• Guide-Arc: Arc Reference line for locating the top edge of the back plate

• Move/Rotate/Zoom Image: Buttons to move/rotate/zoom the Reference image

• Draw Image: Displays the [Reference Image Result Window]

• Reset Image: Resets the Reference image to its initial state (reverts any move/rotate/zoom)

• Clear All: Deletes all values including the image

※ For Guide-w1/2/3, two vertical lines are drawn symmetrically about x=0. The total width between them (i.e., twice the

input value) is automatically calculated and displayed as w=0.00.
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5.4 Reference Image Result Window

※ Added in v.3.0.0.

This is the [Reference Image Result Window] that appears when the [Draw Image] button is clicked after loading an

image in the [Reference Image Setting Window]. Use this screen to adjust the image position, size, and orientation in real

time. Enabling a Reference line in the Setting Window displays that line at the specified position. The Reference image is

always displayed in grayscale (color photos are converted to grayscale).

Figure 9: Reference Image Result Window
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6 General Workflow

6.1 Designing Without a Reference Image

1. Enter design name (Area A)

2. Apply Preset (Area A, click instrument button)

3. Adjust output options (Area D, select items to display in the [Result Window])

4. Modify basic settings (Area B)

5. Adjust instrument dimensions (Area B)

6. Adjust curve shapes (Area C)

7. Check design (Area E, click [Calc...] button)

8. Revise design (if needed, repeat steps 5–7)

9. Save design (when finalized, Area E, click [Save...] button)

10. Save setting values (when finalized, click [File > Export] button)

6.2 Designing With a Reference Image

1. Enter design name (Area A)

2. Apply Preset (Area A, click instrument button)

3. Adjust output options (Area D, select items to display in [Result Window], turn [Ref. Image] On)

4. Modify basic settings (Area B)

5. Select Reference image (click [Tools > Reference Image])

6. Adjust Reference image (adjust the Reference image in the [Reference Image Setting Window])

7. Adjust instrument dimensions (Area B)

8. Adjust curve shapes (Area C)

9. Check design (Area E, click [Calc...] button)

10. Revise design (if needed, repeat steps 7–9)

11. Save design (when finalized, Area E, click [Save...] button)

12. Save setting values (when finalized, click [File > Export] button)

6.3 Designing Using Previously Saved Setting Values

1. Import setting values (click [Tools > Import] button)

2. Revise design (if needed)

3. Save design (when finalized, Area E, click [Save...] button)

4. Save setting values (when finalized, click [File > Export] button)
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7 Detailed Feature Descriptions

7.1 Help Features – Area (A)

These items are provided to assist with the design process and are not mandatory.

■ MODEL NAME

※ In v.3.0.0, the position of this field has been changed.

Enter the name of the drawing. The text entered here will be recorded in the [Result Window] and in all saved files.

■ PRESET

※ In v.3.0.0, the position and appearance of this feature have been changed.

This feature is provided for convenience. Clicking the desired instrument button automatically fills in all input fields with

pre-configured initial values. To clear all values at once, click the [Delete All Value] button.

■ POINT GUIDE

There is no need to memorize all the control points and reference points. This diagram allows you to check the position of

each point.
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7.2 Basic Settings – Area (B)

In Area (B), GEOMETRY, you set the basic parameters and instrument dimensions needed to use the program. First,

configure the basic settings as described here.

■ A. Instrument

Select the instrument to be drawn: violin, viola, or cello. This option is used to automatically set the axis range of the

graph displayed in the [Result Window] and saved to the PDF file.

■ B. Width of Corner & Junction

Select the method for determining the width of the corners (X1X2, Y 1Y 2) and corner junctions (P1P2, Q1Q2). Existing

design methods share a common problem: the approach used for violin cannot be applied to larger instruments such as

cello or viola, making them non-universal. (Corners: X1, X2, Y1, Y2; corner junctions: P1, P2, Q1, Q2)

To solve this, the program introduces a new method that can be applied universally regardless of instrument size (Method

of H.I.S.). The corner junction is always located on the vertical line through the corner, so the width of the corner and the

width of the corner junction are always equal (i.e.,X1X2 = P1P2, Y 1Y 2 = Q1Q2).

※ While this method produces good results regardless of instrument size, it does not guarantee the most beautiful result

or the best sound. Use it as a starting point when the corner width has not yet been decided.

Selecting [Auto (Method of H.I.S)] automatically calculates the corner (and corner junction) widths. Selecting [Use My

Value] uses the values entered directly by the user (items 13, 14, 15, 16 in Area (B)). The calculation principle for [Auto

(Method of H.I.S)] is shown below. - Figure 10 -

※ Method for determining corner and corner junction positions (Method of H.I.S.)

1. Draw a straight line connecting points U1 and L1.

2. On the vertical centerline, find the point that is twice the distance from X to U above point X. Call this point K.

3. Find the intersection of the horizontal line through K and the diagonal line from step 1. Call this point R.

4. Find the intersection of the vertical line dropped from R and the horizontal line through X. This point is X1, the

position of the upper corner.

5. Find the intersection of the horizontal line through P and the vertical line through X1. This point is P1, the position

of the upper corner junction.

6. Draw a straight line connecting points X1 and L1.

7. Find the intersection of the horizontal line through Y and the diagonal line from step 6. This point is Y1, the position

of the lower corner.

8. Find the intersection of the horizontal line through Q and the vertical line through Y1. This point is Q1, the position

of the lower corner junction.
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Figure 10: Method for determining corner and corner junction positions (Method of H.I.S.)

Therefore, the upper corner width (X1X2) is twice the distance from X to X1, and the lower corner width (Y 1Y 2) is

twice the distance from Y to Y1. However, in step 2, if the point K (twice the distance XU above X) is higher than point

A (i.e., 2*UX> AX , or KX > AX), then point A is used as K. In other words, the maximum y-coordinate of K equals

the y-coordinate of A. This situation occurs mainly with larger instruments such as cello, where the distance between U

and X is large.

The corner width determined by [Auto (Method of H.I.S)] is influenced by the difference in width between the U-Bout

and L-Bout, and by the lengths of UX and Y L. A larger difference in width between U-Bout and L-Bout results in a

narrower corner, and longer UX and Y L distances also result in a narrower corner. (The heights of points P and Q are

not automatically calculated and must be set manually (items 8 and 9). Moving point P slightly higher will also raise point

P1.)
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■ C. Set Axes

Sets the range of the horizontal and vertical axes displayed in the [Result Window]. You can choose between automatic and

manual settings. Selecting [Auto] automatically sets the axis range to match the selected instrument size. To set manually,

select [Use My Value] and enter the desired axis range in the fields below. Enter the minimum and maximum values for

both the X and Y axes. Since the axis unit is [mm], if the violin body length is 355mm, the Y-axis minimum should be set

slightly below 0 and the maximum above 355 to display the full curve.

■ D. Set Canvas Size

Sets the canvas size of the [Result Window]. This should be configured with reference to your monitor resolution. For

example, if your monitor resolution is [1024 * 768], the maximum allowable canvas size is approximately [10 * 7.7]. A

canvas size value of ‘1’ corresponds to 100 dpi on the monitor.

You can select either [Auto] or [Use My Value]. In Auto mode, the vertical size is fixed at ‘10’ and the horizontal size is

automatically adjusted in proportion to the axis range. If your monitor resolution is low, manual setting is recommended.
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7.3 Instrument Dimensions – Area (B)

In Area (B), GEOMETRY, set the instrument dimensions. The dimensions are determined by the positions of the control

points and reference points. Refer to the diagram in Area (A) and enter the desired values. Note that all values refer to the

mould dimensions, not the actual top/back plate dimensions. For example, if the desired body length is 355mm and the

edge overhang is 3.5mm, the mould length is 355 - 2 × 3.5 = 348, so enter 348 in [2.(AZ) Length of Mould]. Similarly, if

you want the U-Bout width of the finished instrument to be 170mm, the mould width is 170 - 2 × 3.5 = 163, so enter 163

in [10.(U1U2) Width of U-Bout].

In [1.(EA) Width of Edge], (EA) is an abbreviation for the distance between points E and A. Throughout the main window,

letters in parentheses denote the distance between two points. In [13.(X1X2) Width of U-Corner(Xw)], (X1X2) means

the distance between points X1 and X2, and (Xw) is its shorthand abbreviation. (In the Result Window, abbreviations

such as Xw are used.)

Following the above, enter values for all 16 items from 1.(EZ)... to 16.(Q1Q2)... (It is convenient to use a Preset to auto-fill

all values first, then modify as needed.)
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7.4 Curve Settings – Area (C)

In Area (C), CURVES, you define the shape of the curves. Since the mould outline is bilaterally symmetrical about the

vertical centerline, the program draws the left-side curves and then mirrors them to complete the right side. Therefore,

all descriptions below refer to the left-side curves. The left side consists of 8 Multi-Clothoid curves, which connect the

control points set in the previous step.

Figure.11 shows the 8 left-side curves. The curve connecting points A and U1 is Curve 1, the curve connecting U1 and P1

is Curve 2, and so on, numbered sequentially from top to bottom. As described in Section 4.4, each Multi-Clothoid curve

has a defined start and end, always beginning at the upper point and ending at the point directly below. The abbreviations

and descriptions related to curves are as follows:

• Curve 1. (AU1) : Curve 1 starting at point A and ending at point U1

• S.Ang.(A): Angle at Start point A

• Cur.(A): Curvature at Start point A

• E.Ang.(U1): Angle at End point U1

• Cur.(U1): Curvature at End point U1

As shown, four values are required to define one Multi-Clothoid curve: the angle (direction) and curvature at the start

point, and the angle and curvature at the end point. However, some of these values are fixed and cannot be changed by the

user. For example, the start angle of Curve 1 must be exactly 180◦, and the end angle must be exactly 270◦. These fixed

values cannot be modified.

Figure 11: 8 Multi-Clothoid curves
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To the left of each angle and curvature input field, the allowable input range is shown, e.g., ( 270 ≤ X ≤ 300 ). Values

outside this range can still be entered and a curve will be generated, but an error message will appear. This range is an

approximate recommended range; values outside it may produce extreme curve shapes.

Adjusting these curve shapes requires a good understanding of the Multi-Clothoid curve principles, so please read Section

4.4 carefully.

Below are brief descriptions of Curves 1–4. Curves 5–8 are similar and their descriptions are omitted.

■ Curve 1. (AU1)

The angle at start point A is fixed at 180◦, because both left and right curves must meet horizontally at this point. The

angle at end point U1 is fixed at 270◦, because the two curves must meet perpendicularly there. As shown in Figure 12,

increasing the curvature makes the overall curve rounder. Use this property to generate the desired curve shape.

(a) S.Cur.(A): 0.0, E.Cur.(U1): 0.0 (b) S.Cur.(A): 0.0, E.Cur.(U1): 13.0

(c) S.Cur.(A): 4.0, E.Cur.(U1): 10.0

Figure 12: Parameter settings for Curve 1

■ Curve 2. (U1P1)

The angle at start point U1 is fixed at 270◦, matching the end angle of Curve 1. For a smoother overall curve, it is

recommended to set the curvature here close to the end curvature of Curve 1. At end point P1, the curve heads roughly

south-southeast, so the angle should be entered within the range [270 < x ≤ 300].
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■ Curve 3. (P1X1)

The angle at start point P1 must match the end angle of Curve 2, so this value is automatically carried over from the value

entered above. When a value is automatically carried over from the previous curve, the label [connected] appears to the

left of the input field. The curvature here has an allowable range of [−50 ≤ x ≤ 50], but in general, a value near ‘0’

produces the most natural-looking curve.

The parameters at the end point of Curve 3 and the start point of Curve 4 are critical in defining the corner shape and

should be chosen carefully. The angle determines the direction the corner tip points and how sharp it appears, while the

curvature determines the shape of the line near the corner tip and its sharpness. Comparing (a) and (c) in Figure 13, the

angles and curvatures are both different, yet the depth of the curves is broadly similar. However, (a) bends immediately at

the tip, while (c) extends straight from the tip.

(a) Ang.:230.0, Cur.:−100.0 (b) Ang.:245.0, Cur.:−100.0 (c) Ang.:245.0, Cur.:0.0

Figure 13: Curve changes with varying end point X1 parameters of Curve 3
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■ Curve 4. (X1M1)

The angle at end point M1 is fixed at 270◦. Like the end point of Curve 3, the angle and curvature at start point X1 are

important factors in defining the corner shape. The curvature at end point M1 determines the shape of the C-Bout: the

closer it is to ‘0’, the flatter the center of the C-Bout becomes.

(a) Ang.:18.0, Cur.:−70.0, E.Cur.:−10.0 (b) Ang.:14.0, Cur.:0.0, E.Cur.:−10.0 (c) Ang.:14.0, Cur.:0.0, E.Cur.:0.0

Figure 14: Curve changes with varying parameters of Curve 4
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7.5 Layer Settings – Area (D)

In Area (D), LAYER, select the items to be displayed/saved in the [Result Window] on screen and in the PDF file. Checking

a box enables display/saving; unchecking disables it. For DXF files, all items are always saved regardless of the checkbox

state. Unchecked items are saved with [Layer Off] status, so they will not be visible when the file is opened in a CAD

program — but they can be made visible by turning the corresponding layer On in the CAD program.

■ Mould Outline

Displays/saves the mould outline. This is the most fundamental item and the primary purpose of the program, making it

the most important line. It is selected by default when the program starts. - Figure 15 -

■ Edge Line, Corner Arc

[Edge Line] is the edge line of the top/back plate, located outside the mould outline. This curve is generated by offsetting

the mould outline outward by the value set in [1.(EA) Width of Edge]. [Corner Arc] draws an arc at each corner tip using

the specified value as the radius. This arc can be used as a reference when designing the corners. - Figure 15 -

(a) Mould Outline (b) Mould Outline + Edge Line (c) Mould Outline + Edge Line + Corner Arc

Figure 15: Mould Outline, Edge Line, Corner Arc

H.I.S. Violin Atelier, Manual, March 2026 Page 24 of 53



The Reconstruction of the Stradivari Arch

■ Point, Name, Value

Displays the control points and reference points. Points, names, and values can each be toggled independently.

In the [Result Window], the value to the right of each central reference point (red box) indicates the distance from point

Z. For example, [Q 117.4] means the distance between point Q and point Z is 117.4[mm]. [Uw 160.0] to the right of U2

means the distance between points U1 and U2 — i.e., the U-Bout width — is 160.0[mm] (yellow box).

The values [a, d, r, c] near the left side and diagonal of each corner are corner-related values (green box) (see ‘Corner

Angle/Tilt’ below). The values [w, h] to the right of the corner indicate the corner block dimensions (blue box). These are

for reference only; the actual corner block size in instrument making is left to the maker’s discretion.

Figure 16: Values displayed in the Result Window – yellow: width, red: distance (height), blue: block size, green: corner
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■ Guide Line, Center(V), Center(H), Block

Various Reference lines can be toggled on or off.

• Guide Line: Horizontal/vertical lines passing through the control points

• Center(V/H): Horizontal and vertical centerlines (physical center of the instrument)

• Block: Corner blocks and horizontal lines

(a) Guide Line (b) Center(V),(H) (c) Block

Figure 17: Guide Line, Center, Block
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■ Corner Ref.

[Corner Ref.] (Corner Reference) is a line connecting corner points X1 and L1, used to visually compare the widths of the

upper and lower corners at a glance. Figure.18(a) shows the case where corner width is set automatically (Method H.I.S.):

following its principle, Y1 lies on the straight line connecting X1 and L1. Figure (b) shows a manually set example (Use

My Value) where the upper corner is wider and the lower corner is narrower.

(a) Auto (Method H.I.S.) (b) Corner width modified manually

Figure 18: Corner Ref. display line
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■ Corner Ang.

[Corner Ang.] (Corner Angle) displays the corner angle, the angle measurement radius, and the tilt line. Figure.19(a)

shows [Corner Ang.] only; Figure (b) shows [Corner Ang.] together with [Guide Line]. In Figure (b), both the upper and

lower corners can be seen pointing slightly above the widest point of the U/L-Bout.

(a) Corner Ang. only (b) Corner Ang. with Guide Line

Figure 19: Corner Ang.

For a detailed explanation of corners, please refer to the following.
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※ Corner Angle (opening angle)

The corners of a string instrument are formed by two curves, not straight lines. Judging or expressing how wide these two

curves open is quite a complex matter. When designing with this program, it can be described by the direction (angle)

values of the two Multi-Clothoid curves at that point — but this value only holds at the very tip of the corner when

infinitely magnified, and differs greatly from what the human eye actually perceives.

Figure 20 illustrates the difference in angle between straight-line corners and curved corners. With straight lines the

angle is constant regardless of where it is measured, but with curves the angle changes depending on the measurement

position. Nevertheless, despite this characteristic of string instrument corners, the human eye is naturally capable of

judging intuitively which of two corners is more obtuse or acute.

(a) Straight-line corner (b) Curved corner

Figure 20: Difference in corner angle

Although the perceived angle varies from person to person, a consistent standard is needed for design work. This means

deciding how far from the corner tip (the angle measurement radius) the angle should be measured. Furthermore, this

principle for determining the measurement point must be consistent regardless of instrument size.

As the overall instrument size increases, the distance from the tip to the measurement point (angle measurement radius)

should also increase. However, if the instrument is larger overall but the C-Bout shape and size including the corner

remain the same, the angle measurement radius should also remain the same. In other words, the angle measurement

radius does not scale perfectly with body length or width. Similarly, if the instrument is smaller but the corner shape and

size are unchanged — only the distance between the two corners has decreased — the angle measurement radius should

again remain the same. From these observations, it can be inferred that the angle measurement radius is influenced only

by the local curves in the immediate vicinity of the corner.

The local curves near the corner are essentially the two curves on either side of the corner tip. For the upper corner,

these are Curves 3 and 4. Curve 4 (the C-Bout) is long and bends consistently in one direction, making it unsuitable as

a reference. The other curve (Curve 3) has an inflection point (point P1) not far from the corner tip where the bending

direction reverses, making it the ideal reference. This is the curve P̃1X1 in Figure 21.

In practice, when designing a corner, the overall size of the corner changes with the length of curve P̃1X1, and the

curvature on the C-Bout side (Curve 4) is designed to be similar to the curvature of P̃1X1. In some cases the curvature of
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Figure 21: Corner angle measurement standard (radius), angle, and tilt

P̃1X1 is determined to match the C-Bout side, but either way the curvatures of the two curves near the tip are designed

to be similar — so the corner shape is greatly influenced by the shape (length and curvature) of curve P̃1X1. Therefore,

the angle measurement radius can also be determined based on curve P̃1X1, specifically using the straight-line distance

between points P1 and X1 as the basis. In other words, a value obtained by dividing the length of line P1X1 by a certain

ratio is used as the corner angle measurement radius.

After testing various ratios, it was concluded that setting the angle measurement radius to 1/3 of the length of P1X1

is most appropriate. Using this value, the angle measurement radii for the violin, viola, and cello presets built into this

program are: violin: 8.8mm, viola: 9.3mm, cello: 15.3mm. If P1X1 is longer, these values will be larger.

Using this method to determine the angle measurement radius, a circle of that radius is drawn at the corner tip. The two

intersection points (L and M) of that circle with the corner curves are marked. The angle formed by these two intersection

points and the corner tip (point X1) — ∠LX1M — is defined as the corner angle. In Figure 21, r is the angle measurement

radius and a is the opening of the corner, i.e., the corner angle.

When comparing corners within a single instrument, both upper and lower corners must use the same standard. Therefore,

once the angle measurement radius is determined for the upper corner, the same radius is used to measure the angle of the

lower corner.
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※ Corner Tilt (Direction)

Along with the corner angle, it is sometimes useful to know the direction the corner tip is pointing — i.e., the tilt of the

corner. Depending on this tilt, the corner may converge inward toward the C-Bout or open outward. Judging the corner

tilt is relatively straightforward. Since the corner angle has already been determined, the bisector of that angle is found.

In Figure 21, the angle between the horizontal line and the line passing through the midpoint N of LM and the tip X1 is

the corner tilt (d: ∠NX1X3). Upper corners have a positive (+) value and lower corners have a negative (-) value. Note

that the corner tilt value is not equal to half the corner angle (d ̸= a/2). The corner tilt indicates how much the bisector

of the corner angle is inclined relative to the horizontal line (line X1X3).

Figure 22: Intersection of the corner tilt line and the vertical centerline

The tilt value (d) alone can be difficult to understand intuitively. A helpful aid is the corner tilt line (the bisector of the

corner angle). Extending this line until it meets the vertical centerline of the instrument gives an intersection point (point

C in Figure 22), which makes the corner tilt easier to judge. This intersection is typically located near the widest point of

the U-Bout for the upper corner, and near the widest point of the L-Bout for the lower corner.

※ Display of Values

Checking [Value] under [LAYER] displays all corner-related values in the [Result Window]. Checking [Corner Ref./Ang.]

displays the related lines. In Figure 16, the green box shows corner-related values. The corner angle measurement radius

is shown as r, the corner angle as a, the corner tilt as d, and the intersection point as c. Note that the angle measurement

radius r is always the same for both upper and lower corners.
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■ Arch Profile

※ Added in v.3.0.0.

[Arch Profile] displays the positions of 6 arch profile cross-sections: the vertical centerline, the widest points of the

U/L-Bout, the narrowest points of the upper and lower corners, and the midpoints between the upper and lower corners1.

The [Result Window] displays the position value (distance from point Z) and the width at each of these locations. This

feature is intended for use in conjunction with the recently released [Violin Arch Designer, v.1.0.0] program: design the

mould outline in this program, then use [Violin Arch Designer, v.1.0.0] to draw the arch profile for each cross-section

based on its width.

Figure 23: Arch Profile

1In some approaches the narrowest point of the C-Bout is used, but here the midpoint between the upper and lower corners is used.
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■ Text Box

Displays all input and analysis values, including the instrument dimensions used in the design, curve parameters, and

proportional values for each section. When displaying the Text Box, it is recommended to leave [C. Set Axes] and [D. Set

Canvas Size] set to [Auto]. Since the Text Box has a fixed size regardless of canvas size, setting the canvas too small may

cause overlapping.

(a) Set Axes and Set Canvas Size in Auto mode (b) When Canvas Size is small

Figure 24: Text Box display

■ Axis, Grid

Displays the canvas axes and grid lines. - Figure 25 -

(a) Axis:Off, Grid:Off (b) Axis:On, Grid:Off (c) Axis:On, Grid:On

Figure 25: Axis and Grid display
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■ Ref.Image

※ Added in v.3.0.0.

Displays the Reference image configured in the [Reference Image Setting Window]. This option must be turned on to

design while viewing the Reference image.

(a) Ref.Image: On (b) Ref.Image: Off

Figure 26: Ref.Image On/Off
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■ Overlap/Redraw/New Graph

※ Added in v.3.0.0.

Select the update method when redrawing the [result graph]. (Only one option can be selected.)

• Overlap Graph: Displays the new design on top of the previous one without erasing it. Use this to overlay and

compare multiple designs.

• Redraw Graph: Erases the previous design and displays the new one.

• New Graph: Keeps the previous result graph as is and opens a new window to display the new design.

(a) Comparison of three instruments (b) Comparison of C-Bout lines

Figure 27: Design comparison using the Overlap Graph option
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7.6 Checking Results and Saving Files – Area (E)

In Area (E), you can display the completed design on screen or save it as a file. The [Calculate & Draw] button displays

the design on screen, and the [Save to Files] button saves it as PDF, DXF, and TXT files.

PDF, DXF, and TXT files are created in the same folder as the program executable (Violin_Designer_v.X.X.X.exe) and

saved with the filename format: [New_Design_yyyy-mm-dd_hh-mm-ss.XXX]

(a) DXF file (b) TXT file

Figure 28: Saved DXF and TXT files
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7.7 Import and Export

※ Added in v.3.0.0.

■ Import

You can load a previously saved config file to immediately recreate an identical design. Click [Tools > Import] in the Main

Window and upload the config file. Once uploaded, click [Calculate & Draw] to view the design on screen immediately,

or click [Save to Files] to output PDF, DXF, and TXT files.

※ The config file does not contain Reference image settings. If you are using a Reference image, it must be re-configured

under [Tools > Reference Image].

■ Export

When a design is complete, click [Tools > Export] in the [Main Window] to save all current setting values to a file. The

saved config file can be reloaded later using the Import feature.

※ Setting values related to the Reference image are not saved in the config file.
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7.8 Using the Reference Image

※ Added in v.3.0.0.

This feature allows you to upload a photo of an instrument (Reference image) and design while viewing it, for cases where

you want to copy, modify, or simply reference the shape of another instrument.

7.8.1 Uploading the Reference Image

1. Prepare a photo of the back of the instrument you wish to reference2. The front (top plate) is not recommended, as

the upper bout is partially obscured by the fingerboard, and older instruments may show significant warping. Use

the highest resolution photo available. The photo must show both the button and the end pin of the back plate.

2. Once the photo is ready, use an image editing tool (such as Photoshop) to crop it so that the entire back plate

(including button and end pin) is visible with minimal margins, then save it. If the instrument is lying on its side,

rotate it upright before saving. When cropping, leave a small margin on the left and right sides of the instrument,

and crop as closely as possible to the button at the top and the end pin at the bottom.

3. Click [Main Window] > [Tools] > [Reference Image] to open the Reference Image Setting Window.

4. Click the [Browse..] button to load the cropped photo.

2The instrument photos used in this manual are photos of the author’s own instruments.
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5. In the [Height of Image] field, enter the vertical length of the image. This value is the actual total length of the

instrument, including the body, button, and end pin. For example, if the crop is made as close as possible to the

button and end pin, and the body length = 355mm, button height = 10mm, end pin length = 8mm, then 355+10+8 =

373, so enter ‘373’. An approximate value is acceptable here.

6. Click [Draw Image] to display the uploaded image in grayscale in the [Reference Image Result Window]. The

Reference image is always displayed in grayscale for easy distinction from the Reference lines, and a crosshair

(Reference line) is always shown at the origin (x, y = 0, 0).

Figure 29: Reference Image Result Window
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7.8.2 Adjusting the Reference Image

For accurate design, the size, position, and tilt of the uploaded image must be precisely matched. For example, if the

actual body length of the instrument in the photo is 355.0mm, it must also measure 355.0mm on the graph, and must be

positioned accurately on the coordinate axes. Since the adjusted image is displayed in the Result Window of the Main

Window exactly as adjusted here, the alignment must be done carefully at this stage.

Image adjustment is performed in the following order: vertical centerline alignment > size adjustment.

※ When zooming or rotating the image, the origin (x, y = 0, 0) is always used as the reference point. Therefore, when

adjusting the tilt or size, the bottom edge of the back plate’s vertical centerline (the edge tip) must always be positioned at

the origin.

※ For precise adjustment, you can zoom in on the image. Use the [Zoom] and [Pan] buttons at the bottom of the [Reference

Image Result Window].

A. Vertical Centerline Alignment

First, the vertical centerline of the instrument must be determined. The choice of centerline is left to the user’s judgment,

and there are approximately three approaches:

• A-1: For a 2-piece back, use the left-right joint line

• A-2: If the joint line is curved or the back is 1-piece, use the imaginary straight line connecting the center of the

button and the center of the end pin

• A-3: Use the imaginary straight line connecting the midpoints of the widest parts of the U-Bout and L-Bout

The following describes how to align the vertical centerline of the instrument to the center of the screen for each of the

three cases. Follow the instructions to align your chosen centerline with the x=0 vertical axis of the graph.
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■ A-1. Using the left-right joint line as the vertical centerline

1. Use the [Move Image] button to move the image so that the bottom end of the joint line (edge tip) is at the origin.

2. Use only the [Rotate Image] button to rotate the image so that the top end of the joint line (near the button) aligns

with the x=0 vertical axis. Do not move (translate) the image, as origin alignment was completed in the previous

step. Once vertical centerline alignment is complete, proceed to the next step (size adjustment).

Figure 30: Vertical centerline alignment complete
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■ A-2. Using the midpoints of the button and end pin as the vertical centerline

1. Use the [Move Image] button to move the image so that the center of the end pin at the bottom of the back plate is

at the origin.

2. Use only the [Rotate Image] button to rotate the image so that the center of the button at the top aligns with the

x=0 vertical axis. Do not move (translate) the image, as origin alignment was completed in the previous step. Once

vertical centerline alignment is complete, proceed to the next step (size adjustment).

Figure 31: Vertical centerline alignment complete
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■ A-3. Using the midpoints of the widest parts of the U-Bout and L-Bout as the vertical centerline

In this case, the outer line of the purfling — not the back plate edge line — is used as the reference (because on older

instruments the edge may be worn and the exact width cannot be determined).

Use the vertical Reference lines [Guide-w1, 2, 3] to mark Reference lines at the widest points (outer purfling line) of the

U-Bout and L-Bout, then adjust the image by moving or rotating it until all four points (both sides of the upper and lower

bouts) align with the Reference lines.

1. First, move the image vertically to set the origin height, then move it horizontally to roughly center it.

2. Enable the vertical Reference lines and enter approximate width values for the widest parts (outer purfling line) of

the U/L-Bout. Each vertical Reference line generates two lines. (Entering 80 creates lines at +80 and -80.)

3. While viewing the vertical Reference lines and image on screen, adjust the Reference line position values and move

the image horizontally until the Reference lines align with the outer purfling line on both sides.
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4. Once the lower bout is aligned, proceed to align the upper bout. Aligning the upper bout requires rotating the image,

which will also shift the lower bout slightly, so readjustment will be needed. Alternate between upper and lower

adjustments until all four points align with the Reference lines, then re-check the origin.

Figure 32: Aligning the U-Bout and final result
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B. Size Adjustment

Once vertical centerline alignment is complete, adjust the size. Two methods are available:

• B-1: Based on the body length (including edge overhang)

• B-2: Based on the mould length

When designing based on an existing instrument, there are two choices for determining the instrument size. One is to

follow the exact dimensions of the original instrument; the other is to make slight modifications. For example, if the orig-

inal body length is 356mm, you may keep it at 356mm, or reduce it slightly to 355mm (the most common current standard).

In the former case, the Reference image should be sized to match a body length of 356mm, and the mould length and edge

overhang should be measured from the image and applied as-is. In the latter case, all three values are decided in advance

by the user, and the mould length (outer purfling line) in the Reference image must be matched to the user-defined value.

Therefore, B-1 applies when building to the exact dimensions of the original instrument, and B-2 applies when building

to a size of your own choosing.

※ For the steps below, vertical centerline alignment from the previous section must already be complete.
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■ B-1. Based on body length

1. Since body length is the reference, confirm that the bottom edge tip of the instrument is at the origin. If it has shifted,

realign it precisely at the origin.

2. Enable the arc Reference line (Guide-Arc) and enter the target body length (e.g., 356) in the (height) field. (The arc

Reference line will be displayed, with its radius set to the default value.)

3. Use the [Zoom Image] buttons to enlarge the image until the outer purfling line at the top of the instrument aligns

with the midpoint of the arc Reference line.
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4. Adjust the radius of the arc Reference line so that the central section of the arc (approximately the width of the neck)

aligns well with the outer purfling line. (Since the purfling line is a curve with gradually changing curvature, it will

not align perfectly with a circular arc — alignment over the neck-width section is sufficient.)

5. Use the [Zoom Image] buttons to reduce the image until the edge line around the button aligns with the arc Reference

line. (The instrument in the Reference image is now exactly 356mm.)

6. Since the bottom of the mould outline drawn in the Main Window is always at the origin (point Z), the bottom of

the instrument’s mould outline must also be at the origin. Therefore, use only the vertical arrow buttons of [Move Image] to

move the image so that the outer purfling line at the bottom of the instrument is at y=0.

※ The arc Reference line is used because the exact top edge of the back plate cannot be determined due to the button. By

matching the arc Reference line — which has the same curvature as the enlarged outer purfling line — to the top edge

area of the back plate, the hidden top edge of the back plate can be located.

This completes the Reference image setup. Simply close the [Reference Image Setting/Result Window] and continue

working in the Main Window. To redo the setup, click [Reset Image] or [Clear All].
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■ B-2. Based on mould length

1. Use only the vertical arrow buttons of [Move Image] to move the image so that the outer purfling line at the bottom of

the instrument is at y=0. (Since vertical centerline alignment is already complete, do not move the image horizontally

or rotate it.)

2. Enable horizontal Reference line (Guide-h1) and enter the mould length (e.g., 347). (The Reference line will be

displayed.)

3. Use the [Zoom Image] buttons in the [Reference Image Setting Window] to enlarge or reduce the image until the

outer purfling line at the top of the instrument aligns with the Reference line.

4. Reference image setup complete. Simply close the [Reference Image Setting/Result Window] and continue working

in the Main Window.
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7.8.3 Designing With the Reference Image

Once the Reference image setup is complete, carry out the actual design work in the [Main Window].

The Reference image setup can be redone at any time independently of the design work in the [Main Window], and

the results are automatically reflected in the Main Window. The various Reference lines in the [Reference Image

Setting/Result Window] can also serve as useful tools during the Main Window design work (e.g., for measuring widths).

The overall workflow is: Reference image setup > apply Preset > adjust control point positions > curve settings.

The following describes the working conditions and detailed steps for copying an instrument directly from the Reference

image.

■ Working Conditions

• Vertical centerline: A-1, left-right joint line

• Instrument size: B-1, based on body length, 355mm (mould length and edge overhang measured from the image)

• Origin alignment: The outer purfling line at the bottom of the instrument is located at y=0.

• Preset: Violin

■ Detailed Steps

1. Complete the Reference image setup.

(Reference image setup operates independently of the Main Window and can be done at any point during the main

workflow.)

2. In the [Main Window], enter the [MODEL NAME].

3. Under [PRESET], select [Violin].

4. Under [B. Width of Corner & Junction], select [Use My Value]. (Since the corner width must be entered manually,

selecting Auto would prevent input.)

5. Under [LAYER], enable [Ref.Image].
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6. Click [Calculate & Draw]. The [Result Window] will display the Reference image and the Preset curve together.

Using this view, modify the design while referring to the Reference image.

Figure 33: [Result Window] showing Reference image and violin Preset design

7. The body length is 355mm, but the mould length is unknown. Measure the mould length from the image in the

[Reference Image Setting Window]: enable [Guide-h2] and adjust the [Guide-h2] line to align with the outer purfling

line at the top of the instrument to obtain the value.
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8. Enter the measured mould length (348.2) into [2.(AZ) Length of Mould] in the [Main Window].

9. Calculate the edge overhang from the body length and mould length, and enter it into [1.(EA) Width of Edge] in the

[Main Window].

(Edge overhang = (body length - mould length) / 2 = (355 - 348.2) / 2 = 3.4)

10. Use the horizontal/vertical Reference lines in the [Reference Image Setting Window] to measure the positions of the

remaining control points (U1, X1, M1, Y1, L1), and enter the values into the corresponding fields under [GEOM-

ETRY] in the [Main Window]. Note that the vertical Reference line value (width) in the [Reference Image Setting

Window] represents only the half-width (left side only), so when entering the value in the [Main Window] you must

enter twice that value — the automatically calculated result is shown to the left of each input field. The positions of

the corner junctions (P1, Q1) should be adjusted appropriately after the positions of X1 and Y1 are confirmed.

Figure 34: Entering values for control point U1 (U-Bout width and height); bottom right: current cursor position

Alternatively, instead of using the Reference lines in the [Reference Image Setting Window], you can directly modify

the values under [GEOMETRY] in the [Main Window]. (Modify the GEOMETRY values while viewing the image,

then click [Calculate & Draw] to immediately check the updated design — repeat as needed.)
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11. Once all control point positions are set, compare the photo and the curves in the [Result Window] and refine the

curve shapes under [CURVES] in the [Main Window] to complete the design. When finished, save the design file

([Save to Files]) and save the setting values ([Export]).

Figure 35: Completed design

H.I.S. Violin Atelier, Manual, March 2026 Page 52 of 53



The Reconstruction of the Stradivari Arch

8 Development and System Environment

This software was developed in a Python 3.10 + Tkinter environment and has been confirmed to run on Windows 11 only.

9 Support & Donation

This software was developed for all string instrument makers,

and is available free of charge with no restrictions on any feature.

Your generous support is a great contribution to the advancement of instrument making.

Donation:

(International) PayPal: https://paypal.me/37510519

Related Websites

H.I.S. Violin Atelier – https://www.hisviolins.com

Copyright © 2026 Hwang, Il-Seok. All rights reserved.

Unauthorized modification and commercial sale are prohibited.
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